Maicol07 - Major issue – Incident details

All systems operational

Major issue

Resolved
Major outage
Started over 1 year agoLasted about 2 hours

Affected

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating this incident.